1

Téma: Arduino problém s instalací

Přeju dobrý den. V obchodě se s el. součástkama jsem zakoupil tady toto:
https://www.gme.cz/100-kompatibilni-klo … atmega16u2
Měla by to být úplně stejné jako arduino uno. Chtěl bych jenom zkusit některé aplikace, zatím konkrétní využití pro to nemám. Hlavně jsem si chtěl zkusit nějaké aplikace se se servem. Četl jsem v RCR seriál o PICAXE a něco i o arduinu tak mi to prostě nedalo to nezkusit.
Arduino IDE jsem nainstaloval bez problémů do PC z arduino. org. Stahoval jsem zip soubor a rozbaloval. Port mám COM3 a je to viditelně zprávně. Chtěl jsem na úvod zkusit rozblikat LEDku na pinu 12, ale nejde to, hlásí to chybu:

at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
...7 more

Přímo v IDE je prográmek na rozblikání LEDky přímo na desce. Je to oranžová LEDka L a je přímo napojená na pin 13. Tento prográmek hlásí to samé.
Pokud přímo fyzicky vytáhnu desku odpojím od USB, program se chová úplně stejně. Takže to vypadá na špatnou instalaci software, nebo nedokončenou, nebo chybu ve verzích.
Verzi Arduino IDE mám 1.8.12.
Windows mám Win XP – toto může být problém. Instalace tohoto Win nenabízí, na arduinu.org verze windowsů začínají na Win7.
Podle mého názoru to vypadá na špatnou nebo neexistující komunikaci s Javou. Nevím, jestli mi tady dokáže někdo poradit, ale byl bych rád za každou radu.

A ještě jedna věc. Když dám samotnou desku do napájení (myšleno USB), tak se trvale rozsvítí LEDka zelená (napájení) – toto je v pořádku. Ale trvale se rozbliká oranžová LEDka L – je toto v pořádku? Problém je v tom, že jsem to funkční nikdy neviděl, takže nemám s čím porovnávat.

Díky moc za odpovědi a přeju hezký den.

Share

Palec nahoru Palec dolu

2

Re: Arduino problém s instalací

co ti to píše při překladu a nahrávání na desku Arduina? Ctělo by to tu napsat všechno co se v dolním stavovém řádku vypisuje. To, co jsi tu dal může být důsledek nějaké chyby dříve.

V prostředí je help a jsou tam demo programy. Stáhnul bych jeden a zkusil přeložit a nahrát.
Chybovou hlášku dej do google anebo na youtube a určitě najdeš postup nápravy.

U mě bylo to, že W7 nahrály nové ovladače USB a bylo vymalováno. Musel jsem najít starší ovladače přesně dané verze podporující USB čip na desce Arduina. U Tebe bych to viděl na opačný problém - staré ovladače.

třeba něco řeší tady https://forum.arduino.cc/index.php?topic=420348.0

Share

Palec nahoru Palec dolu

3

Re: Arduino problém s instalací

Vlastně hned na začátku se to pokaždé zastavuje, pokaždé to píše tady toto:

at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
...7 more

Podle google mám smazat nějaké soubory v asdresáři arduino15, ale já nic takového nenašel.
Mám na to stejný názor, asi by pomohla starší verze IDE nebo novější verze Win. V práci máme Win10, tak to tam asi zkusím. A zároveň se pokusím najít starší verzi IDE. To blikání L LEDky je normální?

Share

Palec nahoru Palec dolu

4

Re: Arduino problém s instalací

Je hotovo. Použil jsem verzi 1.6.11 a všechno hned funguje tak, jak má. Vše se zprávně nahrává, program Blinking funguje, oranžová LEDka L bliká kažkou jednu sekundu. Díky za zprávné navedení na řešení.

Share

Palec nahoru Palec dolu

5

Re: Arduino problém s instalací

Aby to tu nevyznělo, že jsem jenom chtěl poradit, tak tu ještě něco málo připíšu.
Po výměně IDE (stahovaný soubor měl označeno, že je pro win XP) jede všechno až překvapivě dobře. S žádnou aplikací jsem neměl vůbec žádné problémy. Ale je pravda, že jsem nic složitějšího nezkoušel. Zkoušel jsem připojit nějaké stará LEDky, posouvat servo do definované polohy, pohybovat se servem pomocí 10k potenciometru. Měl jsem k tomu ještě EEPROM, zkoušel jsem zápis, čtení a mazání s použitím monitoru sériové linky. Tady už bylo vidět, že bez studia to není až tak jednoduché.
Modelářsky mi připadají tyto věcičky celkem dost zajímavé. Už jenom použití na poziční světla, pohyb dělové věže servem apod. Předem sepsaný programů je dost, stačí pohledat.

http://www.mo-na-ko.net/php/portal/img/m/600/t/s36.jpg

Share

Palec nahoru Palec dolu